summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2016-10-08 08:36:23 +0100
committerMarius Bakke <marius@gnu.org>2020-06-14 23:15:21 +0200
commitb1342a82576544fda4777c80267ada7945ae7e4d (patch)
tree46e706c10af7a1b8c17fac22e8ac926799b852a4 /gnu/packages/haskell-web.scm
parentbb9a99e6571c492d30f95c5b51ead6861d1dc098 (diff)
downloadguix-patches-b1342a82576544fda4777c80267ada7945ae7e4d.tar
guix-patches-b1342a82576544fda4777c80267ada7945ae7e4d.tar.gz
gnu: Add ghc-curl.
* gnu/packages/haskell-web.scm (ghc-curl): New public variable.
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 4689025432..0c79ece194 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@gmail.com>
+;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -93,6 +94,27 @@ for screen-scraping.")
(description "HTTP cookie parsing and rendering library for Haskell.")
(license license:bsd-3)))
+(define-public ghc-curl
+ (package
+ (name "ghc-curl")
+ (version "1.3.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://hackage/package/curl/curl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0vj4hpaa30jz7c702xpsfvqaqdxz28zslsqnsfx6bf6dpwvck1wh"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("curl" ,curl)))
+ (home-page "https://hackage.haskell.org/package/curl")
+ (synopsis "Haskell bindings for libcurl")
+ (description
+ "@code{libcurl} is a versatile client-side URL transfer library.
+This package provides a Haskell binding to libcurl.")
+ (license license:bsd-3)))
+
(define-public ghc-httpd-shed
(package
(name "ghc-httpd-shed")