summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-12-04 20:15:41 +0100
committerTimothy Sample <samplet@ngyro.com>2020-12-06 21:35:05 -0500
commit8bbb759c834e2c429e5657481acd5c067c3ba1e8 (patch)
treedd3df86381647b47a1165ff96751551da54f349c /gnu/packages/haskell-web.scm
parent4cb78021218fef3b45f16725873b54cf1206363f (diff)
downloadguix-patches-8bbb759c834e2c429e5657481acd5c067c3ba1e8.tar
guix-patches-8bbb759c834e2c429e5657481acd5c067c3ba1e8.tar.gz
gnu: Add ghc-hjsmin.
* gnu/packages/haskell-web.scm (ghc-hjsmin): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 88f7b6e1d9..745bbecdcc 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -2119,3 +2119,35 @@ HTML responses using CSS selectors.")
Interface (WAI) application for static serving. It also provides some
helper functions and datatypes for use outside of WAI.")
(license license:expat)))
+
+(define-public ghc-hjsmin
+ (package
+ (name "ghc-hjsmin")
+ (version "0.2.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "hjsmin/hjsmin-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1r2p5rjdjr25j3w4s57q5hxw2c3ymw12x7ms18yvglnq2ivr9fc1"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'fix-dist-directory-for-tests
+ (lambda _
+ (substitute* '("test/test-cli.hs" "test/cli/core/runner")
+ (("dist-newstyle") "dist")))))))
+ (inputs
+ `(("ghc-language-javascript" ,ghc-language-javascript)
+ ("ghc-optparse-applicative" ,ghc-optparse-applicative)))
+ (native-inputs
+ `(("ghc-extra" ,ghc-extra)))
+ (home-page "https://github.com/erikd/hjsmin")
+ (synopsis "Haskell implementation of a JavaScript minifier")
+ (description "This library provides tools reduce the size of
+JavaScript files by stripping out extraneous whitespace and other
+syntactic elements, without changing the semantics.")
+ (license license:bsd-3)))