summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-12-04 20:15:44 +0100
committerTimothy Sample <samplet@ngyro.com>2020-12-06 21:35:35 -0500
commit897f47bc6abb88820244fb23ceba75bb9f7c705d (patch)
tree8619ddc445d82220f1d4aee8f12a15a270a3e9f2 /gnu/packages/haskell-web.scm
parent36017770f7cbd49d9d5752c4e8b72cb685a549cd (diff)
downloadguix-patches-897f47bc6abb88820244fb23ceba75bb9f7c705d.tar
guix-patches-897f47bc6abb88820244fb23ceba75bb9f7c705d.tar.gz
gnu: Add ghc-wai-cors.
* gnu/packages/haskell-web.scm (ghc-wai-cors): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 51a54566a7..0be9890d23 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -2224,3 +2224,49 @@ for the Yesod Web Framework.")
launching and inserts JavaScript code to ping the server. When the
server no longer receives pings, it shuts down.")
(license license:expat)))
+
+(define-public ghc-wai-cors
+ (package
+ (name "ghc-wai-cors")
+ (version "0.2.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "wai-cors/wai-cors-" version ".tar.gz"))
+ (sha256
+ (base32
+ "10gv3jjlkcb13031frr818p56v2s0qf6dqjsfpwlhwdxdssvx5r5"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; As of version 0.2.7, there are two test suites: "unit-tests"
+ ;; and "phantomjs". Since we do not have a PhantomJS package,
+ ;; we only run the unit tests.
+ (replace 'check
+ (lambda _
+ (invoke "runhaskell" "Setup.hs" "test" "unit-tests"))))))
+ (inputs
+ `(("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-base-unicode-symbols" ,ghc-base-unicode-symbols)
+ ("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-wai" ,ghc-wai)))
+ (native-inputs
+ `(("ghc-network" ,ghc-network)
+ ("ghc-wai-websockets" ,ghc-wai-websockets)
+ ("ghc-warp" ,ghc-warp)
+ ("ghc-websockets" ,ghc-websockets)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-wai-extra" ,ghc-wai-extra)
+ ("ghc-wai-websockets" ,ghc-wai-websockets)
+ ("ghc-warp" ,ghc-warp)
+ ("ghc-websockets" ,ghc-websockets)))
+ (home-page "https://github.com/larskuhtz/wai-cors")
+ (synopsis "Cross-Origin Resource Sharing (CORS) for WAI")
+ (description "This package provides an implemenation of Cross-Origin
+Resource Sharing (CORS) for the Web Application Framework (WAI) that
+aims to be compliant with @url{https://www.w3.org/TR/cors}.")
+ (license license:expat)))