summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-08 02:25:25 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:48 -0500
commit81b228ed14f50ff1d441d14c24520b226fbbd351 (patch)
tree313cc97134b42f470e69dab5412b67604669dbab /gnu/packages/haskell-web.scm
parentb4a00fecfd8c21ebce88d5ac9b23e61315e739a2 (diff)
downloadguix-patches-81b228ed14f50ff1d441d14c24520b226fbbd351.tar
guix-patches-81b228ed14f50ff1d441d14c24520b226fbbd351.tar.gz
gnu: ghc-bsb-http-chunked: Disable tests on i686-linux.
* gnu/packages/haskell-web.scm (ghc-bsb-http-chunked)[arguments]: Disable tests on i686-linux.
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index ad80831390..1672170131 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -532,6 +532,11 @@ Haskell's Web Application Interface (WAI).")
(base32
"0z0f18yc6zlwh29c6175ivfcin325lvi4irpvv0n3cmq7vi0k0ql"))))
(build-system haskell-build-system)
+ (arguments
+ `(;; XXX: As of 0.0.4, one property test ("Identical output as Blaze")
+ ;; fails on i686-linux.
+ #:tests? ,(not (string-prefix? "i686" (or (%current-target-system)
+ (%current-system))))))
(native-inputs
`(("ghc-attoparsec" ,ghc-attoparsec)
("ghc-blaze-builder" ,ghc-blaze-builder)