summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 11:44:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:12 +0200
commit4aa46e40e8b9ad1ba29ed7f50b26419bb5134016 (patch)
tree18437a8d5509193130e99031d932845166fba125 /gnu/packages/haskell-web.scm
parent83c4a5bd38bdcd39a2bf6645a3b02e93cf9a277b (diff)
downloadguix-patches-4aa46e40e8b9ad1ba29ed7f50b26419bb5134016.tar
guix-patches-4aa46e40e8b9ad1ba29ed7f50b26419bb5134016.tar.gz
gnu: ghc-http: Update to 4000.3.12.
* gnu/packages/haskell-web.scm (ghc-http): Update to 4000.3.12. [native-inputs]: Add ghc-httpd-shed, ghc-test-framework, and ghc-test-framework-hunit. [inputs]: Add ghc-case-insensitive, ghc-conduit, ghc-conduit-extra, ghc-http-types, ghc-puremd5, and ghc-split.
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm27
1 files changed, 17 insertions, 10 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index b4d7e9cce6..a043ffcc0d 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -147,29 +147,36 @@ both client and server code).")
(define-public ghc-http
(package
(name "ghc-http")
- (version "4000.3.3")
+ (version "4000.3.12")
(outputs '("out" "doc"))
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://hackage.haskell.org/package/HTTP/HTTP-"
- version
- ".tar.gz"))
+ (uri (string-append "https://hackage.haskell.org/package/HTTP/"
+ "HTTP-" version ".tar.gz"))
(sha256
(base32
- "1wlvvqcxsnd2is3khsla0vd8i9cy12v1pg6d6i13ihcd131a7bdv"))))
+ "140r6qy1ay25piv0z3hih11zhigyi08nkwc32097j43pjff6mzx3"))))
(build-system haskell-build-system)
(native-inputs
- `(("ghc-hunit" ,ghc-hunit)))
+ `(("ghc-httpd-shed" ,ghc-httpd-shed)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
(inputs
- `(("ghc-old-time" ,ghc-old-time)
+ `(("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-old-time" ,ghc-old-time)
("ghc-parsec" ,ghc-parsec)
+ ("ghc-puremd5" ,ghc-puremd5)
("ghc-mtl" ,ghc-mtl)
("ghc-network" ,ghc-network)
- ("ghc-network-uri" ,ghc-network-uri)))
+ ("ghc-network-uri" ,ghc-network-uri)
+ ("ghc-split" ,ghc-split)))
(arguments
- `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
+ `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
(home-page "https://github.com/haskell/HTTP")
(synopsis "Library for client-side HTTP")
(description