summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2018-03-21 03:44:44 +0000
committerLudovic Courtès <ludo@gnu.org>2018-03-31 19:25:40 +0200
commit448d6226e35dbeaed58a4a0145cc7b539ed6e0b4 (patch)
tree00ec95db38191b639f7e9fb810ce6860af214fa8 /gnu/packages/haskell-web.scm
parentb2b4575dca7582e40ad7819465a91d7834c81e92 (diff)
downloadguix-patches-448d6226e35dbeaed58a4a0145cc7b539ed6e0b4.tar
guix-patches-448d6226e35dbeaed58a4a0145cc7b539ed6e0b4.tar.gz
gnu: Add ghc-path-pieces.
* gnu/packages/haskell-web.scm (ghc-path-pieces): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 1190bc63a5..edfb43c085 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -901,3 +901,27 @@ of a JSON value into a @code{Data.Aeson.Value}.")
(synopsis "Unicode aware uri-encoding")
(description "Unicode aware uri-encoding for Haskell.")
(license license:bsd-3)))
+
+(define-public ghc-path-pieces
+ (package
+ (name "ghc-path-pieces")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "path-pieces-" version "/"
+ "path-pieces-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0vx3sivcsld76058925hym2j6hm3g71f0qjr7v59f1g2afgx82q8"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-text" ,ghc-text)))
+ (native-inputs `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "https://github.com/yesodweb/path-pieces")
+ (synopsis "Used in Yesod to automatically marshall data in the request path")
+ (description "This Haskell package provides two typeclasses for converting
+Haskell data types to and from route pieces.")
+ (license license:bsd-3)))