summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-25 14:28:33 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-11-02 09:32:49 +0100
commit2b1d7b28d384329d92787bebc3ed31516c5e2fec (patch)
tree48f18faad637c289680ae17b629c28bb22c109f1 /gnu/packages/haskell-web.scm
parent79864292f999f87072f0450e9b74d73e6664391c (diff)
downloadguix-patches-2b1d7b28d384329d92787bebc3ed31516c5e2fec.tar
guix-patches-2b1d7b28d384329d92787bebc3ed31516c5e2fec.tar.gz
gnu: ghc-wai-extra: Update to 3.1.7.
* gnu/packages/haskell-web.scm (ghc-wai-extra): Update to 3.1.7. [inputs]: Remove ghc-lifted-base, ghc-stringsearch, ghc-zlib, ghc-void, and ghc-unix-compat; add ghc-call-stack. [native-inputs]: Add ghc-zlib.
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index ad8713dbd8..2c945d93ab 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -539,7 +539,7 @@ communication between web applications and web servers.")
(define-public ghc-wai-extra
(package
(name "ghc-wai-extra")
- (version "3.1.6")
+ (version "3.1.7")
(source
(origin
(method url-fetch)
@@ -549,35 +549,32 @@ communication between web applications and web servers.")
".tar.gz"))
(sha256
(base32
- "03bbhmy8dc2ivhgbsrc39wk5kb9ci4p98pb2qcq2w92imy710cj6"))))
+ "1avf7bjcsbs8l6klp5kkd0cd2dc5n0j0a2yf8813pnwfn5b7qyd4"))))
(build-system haskell-build-system)
(inputs
`(("ghc-ansi-terminal" ,ghc-ansi-terminal)
("ghc-base64-bytestring" ,ghc-base64-bytestring)
+ ("ghc-call-stack" ,ghc-call-stack)
("ghc-cookie" ,ghc-cookie)
("ghc-network" ,ghc-network)
- ("ghc-lifted-base" ,ghc-lifted-base)
("ghc-streaming-commons" ,ghc-streaming-commons)
- ("ghc-stringsearch" ,ghc-stringsearch)
("ghc-resourcet" ,ghc-resourcet)
("ghc-fast-logger" ,ghc-fast-logger)
("ghc-wai-logger" ,ghc-wai-logger)
- ("ghc-zlib" ,ghc-zlib)
("ghc-word8" ,ghc-word8)
("ghc-iproute" ,ghc-iproute)
- ("ghc-void" ,ghc-void)
("ghc-wai" ,ghc-wai)
("ghc-http-types" ,ghc-http-types)
("ghc-http2" ,ghc-http2)
("ghc-case-insensitive" ,ghc-case-insensitive)
("ghc-data-default-class" ,ghc-data-default-class)
- ("ghc-unix-compat" ,ghc-unix-compat)
("ghc-vault" ,ghc-vault)
("ghc-aeson" ,ghc-aeson)))
(native-inputs
`(("hspec-discover" ,hspec-discover)
("ghc-hspec" ,ghc-hspec)
- ("ghc-hunit" ,ghc-hunit)))
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-zlib" ,ghc-zlib)))
(home-page "https://github.com/yesodweb/wai")
(synopsis "Some basic WAI handlers and middleware")
(description "This library provides basic WAI handlers and middleware