summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2019-12-04 01:29:20 -0600
committerBrett Gilio <brettg@posteo.net>2019-12-06 15:48:05 -0600
commit0ef07d79b9c2185af868abc12ccce4e0e4319552 (patch)
tree22aec3bb6ecbb33ddb25e79d9f0e07a4550aa601 /gnu/packages/haskell-web.scm
parent72a0706f44e615b139ff4170634b95a05c461a30 (diff)
downloadguix-patches-0ef07d79b9c2185af868abc12ccce4e0e4319552.tar
guix-patches-0ef07d79b9c2185af868abc12ccce4e0e4319552.tar.gz
gnu: Add ghc-sendfile.
* gnu/packages/haskell-web.scm (ghc-sendfile): New variable. Signed-off-by: Brett Gilio <brettg@posteo.net>
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 1672170131..6098ad5759 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1527,3 +1527,24 @@ The first three components of the version number match the upstream flot
version. The package is designed to meet the redistribution
requirements of downstream users (e.g. Debian).")
(license license:expat)))
+(define-public ghc-sendfile
+ (package
+ (name "ghc-sendfile")
+ (version "0.7.11.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/sendfile/sendfile-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0988snmx3bylpw3kcq8hsgji8idc6xcrcfp275qjv3apfdgc9rp0"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-network" ,ghc-network)))
+ (home-page
+ "https://hub.darcs.net/stepcut/sendfile")
+ (synopsis "Portable sendfile library for Haskell")
+ (description
+ "Haskell library which exposes zero-copy sendfile functionality in a portable way.")
+ (license license:bsd-3)))