summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-crypto.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-29 00:34:16 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:18 +0200
commitbb84b01d51c3293fdd56e0907be87ac94f593197 (patch)
treeea0fbf68e7265b410005872e8edf1149ead6209d /gnu/packages/haskell-crypto.scm
parentddbe020756f65176d7a693b02f54e71bdd1b0685 (diff)
downloadguix-patches-bb84b01d51c3293fdd56e0907be87ac94f593197.tar
guix-patches-bb84b01d51c3293fdd56e0907be87ac94f593197.tar.gz
gnu: ghc-x509-validation: Update to 1.6.10.
* gnu/packages/haskell-crypto.scm (ghc-x509-validation): Update to 1.6.10. [native-inputs]: Add ghc-tasty and ghc-tasty-hunit.
Diffstat (limited to 'gnu/packages/haskell-crypto.scm')
-rw-r--r--gnu/packages/haskell-crypto.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index a4e0a22faf..ff44970be0 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -481,7 +481,7 @@ collections, certificates, revocation lists, and exception lists.")
(define-public ghc-x509-validation
(package
(name "ghc-x509-validation")
- (version "1.6.5")
+ (version "1.6.10")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
@@ -489,7 +489,7 @@ collections, certificates, revocation lists, and exception lists.")
version ".tar.gz"))
(sha256
(base32
- "190w1sr3w6w49v3yvqz4grb0v09ym4gll3n8bxwijvbvcybk3xyi"))))
+ "1ms51scawldgyfcim5a2qlgyn3rnrclyh205d6djaa1569vrs73n"))))
(build-system haskell-build-system)
(inputs
`(("ghc-memory" ,ghc-memory)
@@ -502,6 +502,9 @@ collections, certificates, revocation lists, and exception lists.")
("ghc-x509" ,ghc-x509)
("ghc-x509-store" ,ghc-x509-store)
("ghc-cryptonite" ,ghc-cryptonite)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
(home-page "https://github.com/vincenthz/hs-certificate")
(synopsis "X.509 certificate and revocation list validation")
(description