summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-crypto.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-25 14:28:32 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-11-02 09:32:48 +0100
commitb042b0458e17cca118fa794efb391429f6426c46 (patch)
treea123c7e538b11a5bba48db5b9b727ec4a57d2cad /gnu/packages/haskell-crypto.scm
parenta37cb428c735a879964f062f66f9636d9b1f8cdf (diff)
downloadguix-patches-b042b0458e17cca118fa794efb391429f6426c46.tar
guix-patches-b042b0458e17cca118fa794efb391429f6426c46.tar.gz
gnu: ghc-cryptohash-md5: Update to 0.11.101.0.
* gnu/packages/haskell-crypto.scm (ghc-cryptohash-md5): Update to 0.11.101.0. [native-inputs]: Remove ghc-hunit; add ghc-tasty-hunit.
Diffstat (limited to 'gnu/packages/haskell-crypto.scm')
-rw-r--r--gnu/packages/haskell-crypto.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index a0ceabc4dd..969bc358ae 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -201,7 +201,7 @@ that hides the C implementation.")
(define-public ghc-cryptohash-md5
(package
(name "ghc-cryptohash-md5")
- (version "0.11.100.1")
+ (version "0.11.101.0")
(source
(origin
(method url-fetch)
@@ -210,17 +210,13 @@ that hides the C implementation.")
"cryptohash-md5-" version ".tar.gz"))
(sha256
(base32
- "1y8q7s2bn4gdknw1wjikdnar2b5pgz3nv3220lxrlgpsf23x82vi"))))
+ "018g13hkmq5782i24b4518hcd926fl6x6fh5hd7b9wlxwc5dn21v"))))
(build-system haskell-build-system)
- (arguments
- `(#:cabal-revision
- ("6" "191nvffcrlyvr5dq99bbdxxl2qx44bla9adkhklyknf7ipqdd4yj")
- #:tests? #f)) ; tests require old version of ghc-hunit (0.9)
(native-inputs `(("ghc-base16-bytestring" ,ghc-base16-bytestring)
("ghc-puremd5" ,ghc-puremd5)
("ghc-tasty" ,ghc-tasty)
- ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
- ("ghc-hunit" ,ghc-hunit)))
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
(home-page "https://github.com/hvr/cryptohash-md5")
(synopsis "MD5 implementation for Haskell")
(description "This Haskell package provides implementation of MD5.")