summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-crypto.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2018-03-21 03:44:47 +0000
committerLudovic Courtès <ludo@gnu.org>2018-03-31 19:26:00 +0200
commitaab6df5b63eb2406c24fd445e44093a2b393324b (patch)
treece22cae43483c6d1b447ec282a32478e014ad533 /gnu/packages/haskell-crypto.scm
parent54f3536d55b265f604c77b81595998a91c6aa4e2 (diff)
downloadguix-patches-aab6df5b63eb2406c24fd445e44093a2b393324b.tar
guix-patches-aab6df5b63eb2406c24fd445e44093a2b393324b.tar.gz
gnu: Add ghc-crypto-cipher-types.
* gnu/packages/haskell-crypto.scm (ghc-crypto-cipher-types): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell-crypto.scm')
-rw-r--r--gnu/packages/haskell-crypto.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index e4d4e56388..b1309c1f24 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -530,3 +530,25 @@ list validation.")
"This package provides a library to handle system accessors and storage
for X.509 certificates.")
(license license:bsd-3)))
+
+(define-public ghc-crypto-cipher-types
+ (package
+ (name "ghc-crypto-cipher-types")
+ (version "0.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "crypto-cipher-types-" version "/"
+ "crypto-cipher-types-" version ".tar.gz"))
+ (sha256
+ (base32
+ "03qa1i1kj07pfrxsi7fiaqnnd0vi94jd4jfswbmnm4gp1nvzcwr0"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-byteable" ,ghc-byteable)
+ ("ghc-securemem" ,ghc-securemem)))
+ (home-page "https://github.com/vincenthz/hs-crypto-cipher")
+ (synopsis "Generic cryptography cipher types for Haskell")
+ (description "This Haskell package provides basic typeclasses and types
+for symmetric ciphers.")
+ (license license:bsd-3)))