summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-crypto.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2020-08-08 16:36:35 -0400
committerRicardo Wurmus <rekado@elephly.net>2020-08-13 16:44:52 +0200
commit54a5fd0791f15108d7c06f0b439e75e049fde249 (patch)
tree9f61b048ad568c43a020d0fb0a5b65178f60c7d2 /gnu/packages/haskell-crypto.scm
parent3f7922cbf5f43418d0cb6d44ba4903f33db8ac61 (diff)
downloadguix-patches-54a5fd0791f15108d7c06f0b439e75e049fde249.tar
guix-patches-54a5fd0791f15108d7c06f0b439e75e049fde249.tar.gz
build-system/haskell: Add 'extra-directories' keyword.
See <https://bugs.gnu.org/39309>. * guix/build-system/haskell.scm (lower): Include the transitive propagated inputs of 'extra-directories' inputs. (haskell-build): Add the 'extra-directories' keyword and pass it through to the builder. * guix/build/haskell-build-system.scm (configure): Use it to select which inputs get passed via 'extra-include-dirs' and 'extra-lib-dirs' to Cabal. * gnu/packages/haskell-xyz.scm (ghc-alsa-core, ghc-hmatrix, ghc-hmatrix-gsl, ghc-hslua, ghc-iwlib, ghc-libyaml, ghc-ncurses, ghc-openglraw, ghc-x11, ghc-x11-xft, ghc-zlib): Set 'extra-directories'. * gnu/packages/haskell-crypto.scm (ghc-digest, ghc-hsopenssl): Likewise.
Diffstat (limited to 'gnu/packages/haskell-crypto.scm')
-rw-r--r--gnu/packages/haskell-crypto.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index b9b350b61a..3c863f6cfa 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -343,6 +343,8 @@ generators, and more.")
(base32
"04gy2zp8yzvv7j9bdfvmfzcz3sqyqa6rwslqcn4vyair2vmif5v4"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:extra-directories ("zlib")))
(inputs
`(("zlib" ,zlib)))
(home-page
@@ -790,6 +792,8 @@ extensions.")
(base32
"0qivl9clmybfglwxqp2sq308rv4ia4rhwshcsc8b029bvpp0mpsi"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:extra-directories ("openssl")))
(inputs
`(("ghc-network" ,ghc-network)
("openssl" ,openssl)))