summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-crypto.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-12-04 20:15:40 +0100
committerTimothy Sample <samplet@ngyro.com>2020-12-06 21:34:57 -0500
commit4cb78021218fef3b45f16725873b54cf1206363f (patch)
tree1afbeeb914df37d41335b8fc7d65c818f99e1a98 /gnu/packages/haskell-crypto.scm
parentfd076aefcdffe83439dcc75fa71c310de37e51e6 (diff)
downloadguix-patches-4cb78021218fef3b45f16725873b54cf1206363f.tar
guix-patches-4cb78021218fef3b45f16725873b54cf1206363f.tar.gz
gnu: Add ghc-cryptonite-conduit.
* gnu/packages/haskell-crypto.scm (ghc-cryptonite-conduit): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/haskell-crypto.scm')
-rw-r--r--gnu/packages/haskell-crypto.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index c92dec9932..032c6fb899 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2017 rsiddharth <s@ricketyspace.net>
;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -838,3 +839,38 @@ implementation of SSL.")
(description "This library contains io-streams routines for secure
networking using OpenSSL (by way of HsOpenSSL).")
(license license:bsd-3)))
+
+(define-public ghc-cryptonite-conduit
+ (package
+ (name "ghc-cryptonite-conduit")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "cryptonite-conduit/cryptonite-conduit-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1bldcmda4xh52mw1wfrjljv8crhw3al7v7kv1j0vidvr7ymnjpbh"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-conduit" ,ghc-conduit)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)
+ ("ghc-cryptonite" ,ghc-cryptonite)
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-memory" ,ghc-memory)
+ ("ghc-resourcet" ,ghc-resourcet)))
+ (native-inputs
+ `(("ghc-conduit-combinators" ,ghc-conduit-combinators)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+ (arguments
+ `(#:cabal-revision
+ ("1" "1hh2nzfz4qpxgivfilgk4ll416lph8b2fdkzpzrmqfjglivydfmz")))
+ (home-page "https://github.com/haskell-crypto/cryptonite-conduit")
+ (synopsis "Cryptonite bridge for conduit")
+ (description "This package provides conduit interfaces for some of
+cryptonite's implementations of cryptographic primitives.")
+ (license license:bsd-3)))