summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-13 00:28:45 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:52 -0500
commitf9cad2a0b9e11514520382b3cd87b144b46e3d1e (patch)
tree250f01524ab1f43a36588f5b550525c45be4aa06 /gnu/packages/haskell-check.scm
parent06966c058db966364445a1008cfe1dc046c1a5f7 (diff)
downloadguix-patches-f9cad2a0b9e11514520382b3cd87b144b46e3d1e.tar
guix-patches-f9cad2a0b9e11514520382b3cd87b144b46e3d1e.tar.gz
gnu: Add ghc-testing-feat.
* gnu/packages/haskell-check.scm (ghc-testing-feat): New variable.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 78b75e0133..c6e89460ea 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -936,3 +936,30 @@ type. This library is intended to supply these modifiers to be used by
testing libraries, in an effort to make properties more portable between
testing frameworks.")
(license license:unlicense)))
+
+(define-public ghc-testing-feat
+ (package
+ (name "ghc-testing-feat")
+ (version "1.1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "testing-feat/testing-feat-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1v2qzzpf1s008g7q6q67glf7vbm1pkpq4rc3ii74f4g6vhfx610r"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-size-based" ,ghc-size-based)
+ ("ghc-testing-type-modifiers" ,ghc-testing-type-modifiers)
+ ("ghc-semigroups" ,ghc-semigroups)))
+ (home-page "https://github.com/JonasDuregard/testing-feat")
+ (synopsis "Functional Enumeration of Algebraic Types")
+ (description "Feat (Functional Enumeration of Algebraic Types)
+provides enumerations as functions from natural numbers to
+values (similar to @code{toEnum} but for any algebraic data type). This
+can be used for SmallCheck-style systematic testing, QuickCheck-style
+random testing, and hybrids of the two.")
+ (license license:bsd-3)))