summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-29 17:08:08 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:08 +0200
commitf54f04756f6d90c9fb3b5e45f3947329287f9b05 (patch)
treea6753738a7b426cf5dfe59bb784f15f6cb1e10ae /gnu/packages/haskell-check.scm
parentdde15fea25b86c75512f204de91bb0c82a152967 (diff)
downloadguix-patches-f54f04756f6d90c9fb3b5e45f3947329287f9b05.tar
guix-patches-f54f04756f6d90c9fb3b5e45f3947329287f9b05.tar.gz
gnu: ghc-mtl: Remove built-in Haskell package.
* gnu/packages/agda.scm (agda)[inputs]: Remove ghc-mtl. * gnu/packages/games.scm (raincat)[inputs]: Remove ghc-mtl. * gnu/packages/haskell-check.scm (ghc-tasty-ant-xml, ghc-tasty-golden, ghc-tasty, ghc-tasty-kat, ghc-tasty-rerun, ghc-crypto-cipher-tests)[inputs]: Remove ghc-mtl. * gnu/packages/haskell-crypto.scm (ghc-asn1-encoding, ghc-pem, ghc-x509, ghc-x509-store, ghc-x509-validation, ghc-x509-system)[inputs]: Remove ghc-mtl. * gnu/packages/haskell-web.scm (ghc-http, ghc-http-conduit, ghc-yesod-core)[inputs]: Remove ghc-mtl. * gnu/packages/haskell.scm (ghc-convertible, ghc-libxml, ghc-cgi, ghc-happy, ghc-haskell-src-exts, ghc-resourcet, cabal-install, ghc-indents, ghc-regex-base, ghc-regex-tdfa-rc, ghc-trifecta, ghc-zip-archive, ghc-logict, ghc-exceptions, ghc-smallcheck, ghc-syb, ghc-fgl, ghc-chasingbottoms, ghc-parsec, ghc-megaparsec, ghc-edisonapi, ghc-edisoncore, ghc-mmorph, ghc-ifelse, ghc-kan-extensions, ghc-lens, ghc-cheapskate, ghc-free, ghc-adjunctions, ghc-equivalence, ghc-texmath, ghc-texmath-for-pandoc-1, ghc-highlighting-kate, ghc-th-reify-many, ghc-th-orphans, ghc-geniplate-mirror, ghc-conduit, ghc-filemanip, ghc-juicypixels, ghc-hslua, ghc-hourglass, ghc-skylighting, ghc-skylighting-for-pandoc-1, ghc-pandoc, ghc-pandoc-1, ghc-pandoc-citeproc, ghc-regex-tdfa, ghc-stmonadtrans, ghc-constraints, ghc-lifted-async, ghc-shelly, ghc-hslogger, ghc-json, shellcheck, ghc-vector-algorithms, ghc-monad-par-extras, ghc-monad-par, ghc-monadrandom, ghc-either, ghc-rebase, ghc-aws, ghc-monad-logger, ghc-persistent, ghc-bytes, ghc-missingh, ghc-operational, ghc-chart)[inputs]: Remove ghc-mtl. (ghc-conduit-combinators)[native-inputs]: Remove ghc-mtl. (ghc-mtl): Remove variable. * gnu/packages/idris.scm (idris)[inputs]: Remove ghc-mtl. * gnu/packages/tls.scm (ghc-tls)[inputs]: Remove ghc-mtl. * gnu/packages/version-control.scm (darcs, git-annex)[inputs]: Remove ghc-mtl. * gnu/packages/wm.scm (xmonad, ghc-xmonad-contrib)[inputs]: Remove ghc-mtl. * gnu/packages/xml.scm (ghc-hxt)[inputs]: Remove ghc-mtl.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 31407ca259..4324c9c44d 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -54,7 +54,6 @@
(inputs
`(("ghc-generic-deriving" ,ghc-generic-deriving)
("ghc-xml" ,ghc-xml)
- ("ghc-mtl" ,ghc-mtl)
("ghc-stm" ,ghc-stm)
("ghc-tagged" ,ghc-tagged)
("ghc-tasty" ,ghc-tasty)))
@@ -140,7 +139,6 @@ Haskell test framework.")
(inputs
`(("ghc-temporary" ,ghc-temporary)
("ghc-tasty" ,ghc-tasty)
- ("ghc-mtl" ,ghc-mtl)
("ghc-optparse-applicative" ,ghc-optparse-applicative)
("ghc-tagged" ,ghc-tagged)
("ghc-async" ,ghc-async)
@@ -197,7 +195,6 @@ timer functions of different operating systems via a unified API.")
(build-system haskell-build-system)
(inputs
`(("ghc-stm" ,ghc-stm)
- ("ghc-mtl" ,ghc-mtl)
("ghc-tagged" ,ghc-tagged)
("ghc-regex-tdfa" ,ghc-regex-tdfa)
("ghc-regex-tdfa-rc" ,ghc-regex-tdfa-rc)
@@ -250,7 +247,6 @@ test framework.")
(build-system haskell-build-system)
(inputs
`(("ghc-tasty" ,ghc-tasty)
- ("ghc-mtl" ,ghc-mtl)
("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
("ghc-tasty-hunit" ,ghc-tasty-hunit)))
(home-page "https://github.com/vincenthz/tasty-kat")
@@ -299,8 +295,7 @@ test-framework.")
"0yg8cicfn3qaazvp4rbanzy3dyk95k3y1kkd4bykvkl9v4076788"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-mtl" ,ghc-mtl)
- ("ghc-optparse-applicative" ,ghc-optparse-applicative)
+ `(("ghc-optparse-applicative" ,ghc-optparse-applicative)
("ghc-reducers" ,ghc-reducers)
("ghc-split" ,ghc-split)
("ghc-stm" ,ghc-stm)
@@ -827,7 +822,6 @@ minimal dependencies.")
"19wqignlq90qwpam01hnmmrxaxh5lkax9l1l6rlbi4a07nvp1dnz"))))
(build-system haskell-build-system)
(inputs `(("ghc-quickcheck" ,ghc-quickcheck)
- ("ghc-mtl" ,ghc-mtl)
("ghc-hunit" ,ghc-hunit)
("ghc-test-framework" ,ghc-test-framework)
("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)