summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorCarlo Holl <carloholl@gmail.com>2020-11-25 12:16:35 -0800
committerLeo Famulari <leo@famulari.name>2020-11-25 21:02:16 -0500
commitf1e73a5caf4a008b7a225520641cf2d14aa2f9be (patch)
tree14a93dffa673b15681ea0bfa1a5ed4f8c9dc624f /gnu/packages/haskell-check.scm
parentdf0e411373298e464dd6971129de01316cfa168c (diff)
downloadguix-patches-f1e73a5caf4a008b7a225520641cf2d14aa2f9be.tar
guix-patches-f1e73a5caf4a008b7a225520641cf2d14aa2f9be.tar.gz
gnu: Add ghc-easytest.
* gnu/packages/haskell-check.scm (ghc-easytest): New variable Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index b5546f97f8..9cef80fca6 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1038,3 +1039,29 @@ regular development cycle and regressions caught early.
See the documentation in \"Test.Inspection\" or the project webpage for more
examples and more information.")
(license license:expat)))
+
+(define-public ghc-easytest
+ (package
+ (name "ghc-easytest")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/easytest/easytest-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0gdyawzlw6d15yz7ji599xjgfr0g7l1iq11ffr4aw3j6g3dc6m8i"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-async" ,ghc-async)
+ ("ghc-random" ,ghc-random)
+ ("ghc-call-stack" ,ghc-call-stack)))
+ (home-page "https://github.com/joelburget/easytest")
+ (synopsis "Testing library for Haskell")
+ (description "EasyTest is a testing toolkit, meant to replace most uses of
+QuickCheck, SmallCheck, HUnit, and frameworks like Tasty, etc. Tests can be
+written with ordinary Haskell code, with control flow explicit and under
+programmer control.")
+ (license license:expat)))