summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
commite3196755e60ba7f1ed9d432e73f26a85e0c8893c (patch)
tree06bc27447f2f72b20a2be0201b41b964af03fc87 /gnu/packages/haskell-check.scm
parentfc9ca46aa6403c90e2ea5c815d813d2dba162dfb (diff)
downloadguix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar
guix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar.gz
gnu: Further simplify package inputs.
This is the result of running: ./pre-inst-env guix style --input-simplification=safe and manually undoing changes on a dozen of packages to reduce rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.)
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 295c42a54c..e647d65a89 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -166,14 +166,14 @@ contains the correct result for the test.")
"0574hbqzxzyv6vsk5kzbf04kz58y0iy8x9ydcj4b8fpncgmgy63g"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-tagged" ,ghc-tagged)
- ("ghc-regex-tdfa" ,ghc-regex-tdfa)
- ("ghc-optparse-applicative" ,ghc-optparse-applicative)
- ("ghc-unbounded-delays" ,ghc-unbounded-delays)
- ("ghc-async" ,ghc-async)
- ("ghc-ansi-terminal" ,ghc-ansi-terminal)
- ("ghc-clock-bootstrap" ,ghc-clock-bootstrap)
- ("ghc-wcwidth" ,ghc-wcwidth-bootstrap)))
+ (list ghc-tagged
+ ghc-regex-tdfa
+ ghc-optparse-applicative
+ ghc-unbounded-delays
+ ghc-async
+ ghc-ansi-terminal
+ ghc-clock-bootstrap
+ ghc-wcwidth-bootstrap))
(home-page "http://documentup.com/feuerbach/tasty")
(synopsis "Modern and extensible testing framework")
(description "Tasty is a modern testing framework for Haskell. It lets
@@ -490,8 +490,7 @@ use HUnit assertions as QuickCheck properties.")
"1wrnrm9sq4s0bly0q58y80g4153q45iglqa34xsi2q3bd62nqyyq"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-random" ,ghc-random)
- ("ghc-splitmix" ,ghc-splitmix-bootstrap)))
+ (list ghc-random ghc-splitmix-bootstrap))
(home-page "https://github.com/nick8325/quickcheck")
(synopsis "Automatic testing of Haskell programs")
(description