summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 23:03:41 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:05 -0500
commitd418ec06579092efaec05fb2a1c19d92386e2ae6 (patch)
tree2d14ee456397ad35e4a75252a8411b6f9c1460b4 /gnu/packages/haskell-check.scm
parent65a16a4500132c1bcf3de910cc2ebbb9ac748f27 (diff)
downloadguix-patches-d418ec06579092efaec05fb2a1c19d92386e2ae6.tar
guix-patches-d418ec06579092efaec05fb2a1c19d92386e2ae6.tar.gz
gnu: ghc-test-framework: Update Cabal file to r5.
* gnu/packages/haskell-check.scm (ghc-test-framework): Update Cabal file to r5, and remove a now unneeded 'update-constraints' phase.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index d861e72687..6c9f5250ae 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -441,13 +441,8 @@ expressed in Haskell, using combinators defined in the QuickCheck library.")
(build-system haskell-build-system)
(arguments
`(#:tests? #f ; FIXME: Tests do not build.
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'update-constraints
- (lambda _
- (substitute* "test-framework.cabal"
- (("QuickCheck >= 2\\.3 && < 2\\.10")
- "QuickCheck >= 2.3 && < 2.12")))))))
+ #:cabal-revision
+ ("5" "18g92ajx3ghznd6k3ihj22ln29n676ailzwx3k0f1kj3bmpilnh6")))
(native-inputs
`(("ghc-hunit" ,ghc-hunit)
("ghc-quickcheck" ,ghc-quickcheck)))