summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-08-23 14:37:57 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-08-23 14:37:57 +0530
commitcdccdec1f2a28f9091372141d25eca380e1c1e53 (patch)
tree789463960283bbf7dfc8c9712a1898a94fa37e79 /gnu/packages/haskell-check.scm
parentf797a0e987c29f3f146a520a355b1a661f7eb79f (diff)
downloadguix-patches-cdccdec1f2a28f9091372141d25eca380e1c1e53.tar
guix-patches-cdccdec1f2a28f9091372141d25eca380e1c1e53.tar.gz
gnu: ghc-quickcheck-instances: Update to 0.3.18.
* gnu/packages/haskell-check.scm (ghc-quickcheck-instances): Update to 0.3.18. [arguments]: Allow building with newer base-compat.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 1d673c606a..c3ef85f3f0 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017 rsiddharth <s@ricketyspace.net>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Tonton <tonton@riseup.net>
+;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -342,7 +343,7 @@ development.")
(define-public ghc-quickcheck-instances
(package
(name "ghc-quickcheck-instances")
- (version "0.3.16.1")
+ (version "0.3.18")
(source
(origin
(method url-fetch)
@@ -352,8 +353,10 @@ development.")
version ".tar.gz"))
(sha256
(base32
- "01v5bs7r9yvhkvb4yc9bqnacy8r6cy2gr9lnmwx40n5apgi0gcbz"))))
+ "1bh1pzz5fdcqvzdcirqxna6fnjms02min5md716299g5niz46w55"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:configure-flags (list "--allow-newer=base-compat")))
(inputs
`(("ghc-quickcheck" ,ghc-quickcheck)
("ghc-base-compat" ,ghc-base-compat)