summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 11:26:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:11 +0200
commita5f7a5f6eddc4a37deadb9988ee8186726f1bc7a (patch)
treee390bd657060d4dac5b97b72d540611b2ab2b212 /gnu/packages/haskell-check.scm
parentf1ac3bba6648484b096a6792940e0e2c55b151e0 (diff)
downloadguix-patches-a5f7a5f6eddc4a37deadb9988ee8186726f1bc7a.tar
guix-patches-a5f7a5f6eddc4a37deadb9988ee8186726f1bc7a.tar.gz
gnu: ghc-test-framework-hunit: Fix build with new HUnit.
* gnu/packages/haskell-check.scm (ghc-test-framework-hunit)[arguments]: Allow newer version of HUnit.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index b2d352050f..1d673c606a 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -530,6 +530,9 @@ reporting and test statistics output.")
(base32
"1y0b6vg8nfm43v90lxxcydhi6qlxhfy4vpxbzm5ic2w55bh8xjwm"))))
(build-system haskell-build-system)
+ ;; The official revision of the cabal file allows for HUnit lower than 1.7
+ (arguments
+ `(#:configure-flags (list "--allow-newer=HUnit")))
(inputs
`(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
("ghc-hunit" ,ghc-hunit)