summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-25 14:28:32 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-11-02 09:32:48 +0100
commita37cb428c735a879964f062f66f9636d9b1f8cdf (patch)
tree3b58cdb1ef1d0e04470b623f8de238814667b816 /gnu/packages/haskell-check.scm
parent5a9e7cdd3245e1ed66dc1f529dc7aa74447ef6a5 (diff)
downloadguix-patches-a37cb428c735a879964f062f66f9636d9b1f8cdf.tar
guix-patches-a37cb428c735a879964f062f66f9636d9b1f8cdf.tar.gz
gnu: ghc-tasty-silver: Update to 3.2.3.
* gnu/packages/haskell-check.scm (ghc-tasty-silver): Update to 3.2.3. [inputs]: Add ghc-semigroups. [native-inputs]: Add ghc-silently.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index c9ba1be280..04d9ff6253 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -1208,7 +1208,7 @@ environment.")
(define-public ghc-tasty-silver
(package
(name "ghc-tasty-silver")
- (version "3.2.2")
+ (version "3.2.3")
(source
(origin
(method url-fetch)
@@ -1217,7 +1217,7 @@ environment.")
version
".tar.gz"))
(sha256
- (base32 "0zsl6nna8ir215qyxhyh2czx4i16hzw1n1m8jw8ym02j6sp6iz13"))))
+ (base32 "0nvh2k8iqqkanmp7lpwd3asimyarzisly8wavbdahcxryn0j4xb7"))))
(build-system haskell-build-system)
(inputs
`(("ghc-ansi-terminal" ,ghc-ansi-terminal)
@@ -1225,13 +1225,13 @@ environment.")
("ghc-optparse-applicative" ,ghc-optparse-applicative)
("ghc-process-extras" ,ghc-process-extras)
("ghc-regex-tdfa" ,ghc-regex-tdfa)
+ ("ghc-semigroups" ,ghc-semigroups)
("ghc-tagged" ,ghc-tagged)
("ghc-tasty" ,ghc-tasty)
("ghc-temporary" ,ghc-temporary)))
- (native-inputs `(("ghc-tasty-hunit" ,ghc-tasty-hunit)))
- (arguments
- `(#:cabal-revision
- ("1" "0mgdk77xz38zc46qbxvss6vnp4yk328zbpw1l0c1n0f5gyf6sbav")))
+ (native-inputs
+ `(("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-silently" ,ghc-silently)))
(home-page "https://github.com/phile314/tasty-silver")
(synopsis "Fancy test runner, including support for golden tests")
(description