summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 11:19:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:10 +0200
commit8d04a5c968c0600b1d2d1e889d189e82d2278971 (patch)
tree3df2ac83e74d1ff0c57c1d3788bfd40f78d19039 /gnu/packages/haskell-check.scm
parentb9ff25999d6b3d947ceacd7d01d3b64ac2c8120d (diff)
downloadguix-patches-8d04a5c968c0600b1d2d1e889d189e82d2278971.tar
guix-patches-8d04a5c968c0600b1d2d1e889d189e82d2278971.tar.gz
gnu: hspec-discover: Update to 2.5.5.
* gnu/packages/haskell-check.scm (hspec-discover): Update to 2.5.5. [arguments]: Enable haddock phase. [inputs]: Move ghc-hspec-meta from here... [native-inputs]: ...to here; add ghc-quickcheck.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 7453f9fbf1..f40bc7ce96 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -626,21 +626,20 @@ JUnit tool for Java.")
(define-public hspec-discover
(package
(name "hspec-discover")
- (version "2.2.4")
+ (version "2.5.5")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://hackage.haskell.org/package/hspec-discover/hspec-discover-"
- version
- ".tar.gz"))
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "hspec-discover/hspec-discover-"
+ version ".tar.gz"))
(sha256
(base32
- "1bz7wb8v0bx1amiz4bpj34xq97d1ia29n3f654wcrh6lacydp3dv"))))
+ "04aidzi91ccr9bygmfkjzshz34z9vh8wvqj4zinx2clxq6r7gqfz"))))
(build-system haskell-build-system)
- (arguments `(#:haddock? #f)) ; Haddock phase fails because there are no
- ; documentation files.
- (inputs `(("ghc-hspec-meta" ,ghc-hspec-meta)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hspec-meta" ,ghc-hspec-meta)))
(home-page "https://hspec.github.io/")
(synopsis "Automatically discover and run Hspec tests")
(description "hspec-discover is a tool which automatically discovers and