summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-07-16 14:43:03 -0400
committerTimothy Sample <samplet@ngyro.com>2019-07-16 14:43:03 -0400
commit71e5d425c9b9e108ebdd06d13de45b56dddd9ef5 (patch)
tree8332eaa475487f230f352d2a2294da6920a5ca9d /gnu/packages/haskell-check.scm
parent6869b6635afd93872b8f0d9f2db0db4c0d765a86 (diff)
downloadguix-patches-71e5d425c9b9e108ebdd06d13de45b56dddd9ef5.tar
guix-patches-71e5d425c9b9e108ebdd06d13de45b56dddd9ef5.tar.gz
gnu: ghc-clock-bootstrap: Move and inherit from ghc-clock.
Fixes <https://bugs.gnu.org/36084>. * gnu/packages/haskell-check.scm (ghc-clock-bootstrap): Move this... * gnu/packages/haskell.scm (ghc-clock-bootstrap): ...here and inherit from ghc-clock (which implies updating to version 0.7.2). Co-authored-by: Robert Vollmert <rob@vllmrt.net>
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 9b010fd5eb..3c10a5284e 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -154,30 +154,6 @@ output file should be identical to the corresponding @code{golden} file, which
contains the correct result for the test.")
(license license:expat)))
-;; This package builds `clock` without tests, since the tests rely on tasty
-;; and tasty-quickcheck, which in turn require clock to build.
-(define ghc-clock-bootstrap
- (package
- (name "ghc-clock-bootstrap")
- (version "0.5.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://hackage.haskell.org/package/"
- "clock/"
- "clock-" version ".tar.gz"))
- (sha256
- (base32 "1ncph7vi2q6ywwc8ysxl1ibw6i5dwfvln88ssfazk8jgpj4iyykw"))))
- (build-system haskell-build-system)
- (arguments `(#:tests? #f)) ;; Testing suite depends on tasty and
- ;; tasty-quickcheck, which need clock to build.
- (home-page "https://hackage.haskell.org/package/clock")
- (synopsis "High-resolution clock for Haskell")
- (description "A package for convenient access to high-resolution clock and
-timer functions of different operating systems via a unified API.")
- (license license:bsd-3)))
-
(define-public ghc-tasty
(package
(name "ghc-tasty")