summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-26 23:59:28 +0100
committerMarius Bakke <marius@gnu.org>2020-11-26 23:59:28 +0100
commit24c86ad0c05bac966c3f5f3c5f40c6b0945adf09 (patch)
tree45160aa4ebe3651a79b5abd76dcefaf8813aa966 /gnu/packages/haskell-check.scm
parentbff94a5a537c2c484f9f6e98cab75195c3dde9e7 (diff)
parent4a914de930a8317cab5bc11bdb608e3a3da3d1ad (diff)
downloadguix-patches-24c86ad0c05bac966c3f5f3c5f40c6b0945adf09.tar
guix-patches-24c86ad0c05bac966c3f5f3c5f40c6b0945adf09.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 6176b95988..df7a667623 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1035,3 +1036,29 @@ regular development cycle and regressions caught early.
See the documentation in \"Test.Inspection\" or the project webpage for more
examples and more information.")
(license license:expat)))
+
+(define-public ghc-easytest
+ (package
+ (name "ghc-easytest")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/easytest/easytest-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0gdyawzlw6d15yz7ji599xjgfr0g7l1iq11ffr4aw3j6g3dc6m8i"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-async" ,ghc-async)
+ ("ghc-random" ,ghc-random)
+ ("ghc-call-stack" ,ghc-call-stack)))
+ (home-page "https://github.com/joelburget/easytest")
+ (synopsis "Testing library for Haskell")
+ (description "EasyTest is a testing toolkit, meant to replace most uses of
+QuickCheck, SmallCheck, HUnit, and frameworks like Tasty, etc. Tests can be
+written with ordinary Haskell code, with control flow explicit and under
+programmer control.")
+ (license license:expat)))