summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 09:52:05 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:02 -0500
commit178f69cb418c0684f986dac1e6126f6ff45d65c6 (patch)
treed486111a135263a8f15f4153fe58b1e67276f40e /gnu/packages/haskell-check.scm
parent6cf0daa4c0b0bca355948c930e33eacfc6a1c727 (diff)
downloadguix-patches-178f69cb418c0684f986dac1e6126f6ff45d65c6.tar
guix-patches-178f69cb418c0684f986dac1e6126f6ff45d65c6.tar.gz
gnu: ghc-quickcheck: Update to 2.13.2.
* gnu/packages/haskell-check.scm (ghc-quickcheck): Update to 2.13.2. [inputs]: Add 'ghc-splitmix-bootstrap'.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index ac41fb7518..d861e72687 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -397,7 +397,7 @@ use HUnit assertions as QuickCheck properties.")
(define-public ghc-quickcheck
(package
(name "ghc-quickcheck")
- (version "2.11.3")
+ (version "2.13.2")
(outputs '("out" "doc"))
(source
(origin
@@ -408,12 +408,13 @@ use HUnit assertions as QuickCheck properties.")
".tar.gz"))
(sha256
(base32
- "0xhqk35fkzlbjcqbabg6962jkv8d688nzmz7ng4bm84x2d95d328"))))
+ "0426j43af8v3qmdjjqxivazsvr3a2brac8yw09vpgpjkb2m0nmkv"))))
(build-system haskell-build-system)
(arguments
`(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
(inputs
`(("ghc-random" ,ghc-random)
+ ("ghc-splitmix" ,ghc-splitmix-bootstrap)
("ghc-tf-random" ,ghc-tf-random)))
(home-page "https://github.com/nick8325/quickcheck")
(synopsis "Automatic testing of Haskell programs")