summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-29 13:20:13 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:11 +0200
commit09b52698babe9a09a4f0aba2f34e1732094b88a1 (patch)
tree1f1e9f265fe12307b885d1874fd676fa2842ae71 /gnu/packages/haskell-check.scm
parent8ebdab0dc4fa389f5238203eb785a1d17cb1d478 (diff)
downloadguix-patches-09b52698babe9a09a4f0aba2f34e1732094b88a1.tar
guix-patches-09b52698babe9a09a4f0aba2f34e1732094b88a1.tar.gz
gnu: ghc-quickcheck: Update to 2.11.3.
This commit also removes extra versions of ghc-quickcheck that have no dependents. * gnu/packages/haskell-check.scm (ghc-quickcheck): Update to 2.11.3. [arguments]: Remove "-f base4" configure flag. (ghc-quickcheck-latest): Delete variable. (ghc-quickcheck-2.9): Delete variable.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm34
1 files changed, 3 insertions, 31 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 4324c9c44d..57e7f0edc1 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -421,7 +421,7 @@ use HUnit assertions as QuickCheck properties.")
(define-public ghc-quickcheck
(package
(name "ghc-quickcheck")
- (version "2.10.1")
+ (version "2.11.3")
(outputs '("out" "doc"))
(source
(origin
@@ -432,11 +432,10 @@ use HUnit assertions as QuickCheck properties.")
".tar.gz"))
(sha256
(base32
- "1rfmns3lj3hl93k1jws85ajkkw7z9ll8cw292n9m7zald1w5dfqx"))))
+ "0xhqk35fkzlbjcqbabg6962jkv8d688nzmz7ng4bm84x2d95d328"))))
(build-system haskell-build-system)
(arguments
- `(#:tests? #f ; FIXME: currently missing libraries used for tests.
- #:configure-flags '("-f base4")))
+ `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
(inputs
`(("ghc-random" ,ghc-random)
("ghc-tf-random" ,ghc-tf-random)))
@@ -450,33 +449,6 @@ hold in a large number of randomly generated cases. Specifications are
expressed in Haskell, using combinators defined in the QuickCheck library.")
(license license:bsd-3)))
-(define-public ghc-quickcheck-2.9
- (package
- (inherit ghc-quickcheck)
- (name "ghc-quickcheck")
- (version "2.9.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://hackage.haskell.org/package/QuickCheck-2.9.2/QuickCheck-"
- version ".tar.gz"))
- (sha256
- (base32
- "119np67qvx8hyp9vkg4gr2wv3lj3j6ay2vl4hxspkg43ymb1cp0m"))))))
-
-(define-public ghc-quickcheck-latest
- (package (inherit ghc-quickcheck)
- (version "2.11.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://hackage.haskell.org/package/QuickCheck/QuickCheck-"
- version
- ".tar.gz"))
- (sha256
- (base32
- "0xhqk35fkzlbjcqbabg6962jkv8d688nzmz7ng4bm84x2d95d328"))))))
-
(define-public ghc-test-framework
(package
(name "ghc-test-framework")