summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2020-08-17 11:03:58 -0400
committerTimothy Sample <samplet@ngyro.com>2020-08-17 11:03:58 -0400
commite13fefbcffa50144d9301d67b61928ac3c964fb3 (patch)
tree71b65d9e3edcfa68ef5de04879b51c460b34e48f /gnu/packages/haskell-apps.scm
parent02554a58a2f149289ae3affa19c2dec915c5b1ef (diff)
downloadguix-patches-e13fefbcffa50144d9301d67b61928ac3c964fb3.tar
guix-patches-e13fefbcffa50144d9301d67b61928ac3c964fb3.tar.gz
gnu: git-annex: Create fake static output.
This is a work-around for a problem introduced by commit 718dc7d4a5e5d26cac80c79d78535677e0379dc8. * gnu/packages/haskell-apps.scm (git-annex)[arguments]: Add a phase to generate the "static" output.
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index c70f1736d7..dac626f10a 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -427,7 +427,17 @@ to @code{cabal repl}).")
(string-append bin "/git-annex-shell"))
(symlink (string-append bin "/git-annex")
(string-append bin "/git-remote-tor-annex"))
- #t))))))
+ #t)))
+ (add-after 'install 'touch-static-output
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; The Haskell build system adds a "static" output by
+ ;; default, and there is no way to override this until
+ ;; <https://issues.guix.gnu.org/41569> is fixed. Without
+ ;; this phase, the daemon complains because we do not
+ ;; create the "static" output.
+ (with-output-to-file (assoc-ref outputs "static")
+ (lambda ()
+ (display "static output not used\n"))))))))
(inputs
`(("curl" ,curl)
("ghc-aeson" ,ghc-aeson)