summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-27 14:41:12 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-10-27 14:41:12 +0200
commitac1b080107b9ebf8219921f460dfad14b3d681ed (patch)
treea2d3e99321bcd01db2d729a3ff84152ebf6a1e33 /gnu/packages/haskell-apps.scm
parentd50f2b7a09ea15564e5672db3d1fede6465c4b0b (diff)
downloadguix-patches-ac1b080107b9ebf8219921f460dfad14b3d681ed.tar
guix-patches-ac1b080107b9ebf8219921f460dfad14b3d681ed.tar.gz
gnu: git-annex: Build with S3 support.
* gnu/packages/haskell-apps.scm (git-annex)[arguments]: Enable S3 in configure-flags. [inputs]: Add ghc-aws.
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index c5e1cd6c64..beecb0392d 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2015 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -256,7 +257,7 @@ unique algebra of patches called @url{http://darcs.net/Theory,Patchtheory}.
(build-system haskell-build-system)
(arguments
`(#:configure-flags
- '("--flags=-Android -Assistant -Pairing -S3 -Webapp -WebDAV")
+ '("--flags=-Android -Assistant -Pairing -Webapp -WebDAV")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-shell-for-tests
@@ -317,6 +318,7 @@ unique algebra of patches called @url{http://darcs.net/Theory,Patchtheory}.
`(("curl" ,curl)
("ghc-aeson" ,ghc-aeson)
("ghc-async" ,ghc-async)
+ ("ghc-aws" ,ghc-aws)
("ghc-bloomfilter" ,ghc-bloomfilter)
("ghc-byteable" ,ghc-byteable)
("ghc-case-insensitive" ,ghc-case-insensitive)