summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-02-24 14:04:54 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-02-24 15:16:30 +0100
commita1386815503036773a1092554f36d45dd9361efe (patch)
tree6d6bfd93cb96ebd66fb16aec1082a2347a7cc4a5 /gnu/packages/haskell-apps.scm
parent212e473e806854c7d1d864a04d5c79158a65bcb4 (diff)
downloadguix-patches-a1386815503036773a1092554f36d45dd9361efe.tar
guix-patches-a1386815503036773a1092554f36d45dd9361efe.tar.gz
gnu: Add greenclip.
* gnu/packages/haskell-apps.scm (greenclip): New variable. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm38
1 files changed, 37 insertions, 1 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 16531cf290..a4b88d22c1 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
;;; Copyright © 2020 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2021 EuAndreh <eu@euandre.org>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,7 +51,8 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages rsync)
- #:use-module (gnu packages version-control))
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages xorg))
(define-public apply-refact
(package
@@ -720,6 +722,40 @@ Wayland, and Linux console environments alike.")
formatting by forgetting all existing formatting during parsing.")
(license license:mpl2.0)))
+(define-public greenclip
+ (package
+ (name "greenclip")
+ (version "3.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/erebe/greenclip")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1baw360dcnyavacf7a8v6wq4m5g6bcmyybkckv4cz7r4xl5p3qws"))))
+ (build-system haskell-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxscrnsaver" ,libxscrnsaver)
+ ("ghc-x11" ,ghc-x11)
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-hashable" ,ghc-hashable)
+ ("ghc-microlens" ,ghc-microlens)
+ ("ghc-microlens-mtl" ,ghc-microlens-mtl)
+ ("ghc-protolude" ,ghc-protolude)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-wordexp" ,ghc-wordexp)))
+ (home-page "https://github.com/erebe/greenclip")
+ (synopsis "Simple Clipboard manager")
+ (description "@code{greenclip} is a clipboard manager written in
+Haskell.")
+ (license license:bsd-3)))
+
(define-public raincat
(package
(name "raincat")