summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2020-09-08 22:16:28 -0400
committerTimothy Sample <samplet@ngyro.com>2020-09-08 23:37:45 -0400
commit8c944c4c4fd6cfe059fd75d1ac5081f414baadfe (patch)
treebef9d7ef5ce229fc76adec0335951f1afb7d6f67 /gnu/packages/haskell-apps.scm
parent56a6748ddd594c9cea8a9412575de62e095752b1 (diff)
downloadguix-patches-8c944c4c4fd6cfe059fd75d1ac5081f414baadfe.tar
guix-patches-8c944c4c4fd6cfe059fd75d1ac5081f414baadfe.tar.gz
gnu: git-annex: Update to 8.20200908.
* gnu/packages/haskell-apps.scm (git-annex): Update to 8.20200908. [arguments]: Drop flag to disable WebDAV because the latest release unconditionally builds with WebDAV support. [inputs]: Add ghc-dav. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index ddcd5c65ce..32e1c50852 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -339,18 +339,18 @@ to @code{cabal repl}).")
(define-public git-annex
(package
(name "git-annex")
- (version "8.20200810")
+ (version "8.20200908")
(source
(origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"git-annex/git-annex-" version ".tar.gz"))
(sha256
- (base32 "1wy6ckcf5f6m94gakg1504h1zryail3mmj85sglq03s45vawjcg6"))))
+ (base32 "1113inl10f4m0699ba2zglaqlfqvwhqjkqg6r6m1d5rqv5brswb1"))))
(build-system haskell-build-system)
(arguments
`(#:configure-flags
- '("--flags=-Android -Assistant -Pairing -Webapp -WebDAV")
+ '("--flags=-Android -Assistant -Pairing -Webapp")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-shell-for-tests
@@ -448,6 +448,7 @@ to @code{cabal repl}).")
("ghc-crypto-api" ,ghc-crypto-api)
("ghc-cryptonite" ,ghc-cryptonite)
("ghc-data-default" ,ghc-data-default)
+ ("ghc-dav" ,ghc-dav)
("ghc-disk-free-space" ,ghc-disk-free-space)
("ghc-dlist" ,ghc-dlist)
("ghc-edit-distance" ,ghc-edit-distance)