summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2020-09-06 09:23:54 -0500
committerAlex Griffin <a@ajgrf.com>2020-09-06 09:24:55 -0500
commit838c8204471877fa1adba1736619241ce014d359 (patch)
tree97ac4c0737584847a90d05fff2882df6b8c1c6f3 /gnu/packages/haskell-apps.scm
parentbf69fa10236af2b85367aa073b8e5b7d2636e151 (diff)
downloadguix-patches-838c8204471877fa1adba1736619241ce014d359.tar
guix-patches-838c8204471877fa1adba1736619241ce014d359.tar.gz
gnu: kmonad: Update to 0.4.0.
* gnu/packages/haskell-apps.scm (kmonad): Update to 0.4.0. [arguments]: Update doc dir for new repo layout. [inputs]: Add new dependencies.
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 2a63712083..ddcd5c65ce 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2019, 2020 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2015 John Soo <jsoo1@asu.edu>
;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
;;; Copyright © 2020 Brian Leung <bkleung89@gmail.com>
;;;
@@ -627,7 +627,7 @@ and mIRC chat codes.")
(define-public kmonad
(package
(name "kmonad")
- (version "0.3.0")
+ (version "0.4.0")
(source
(origin
(method git-fetch)
@@ -636,7 +636,7 @@ and mIRC chat codes.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1g40nkpldih6h1rlxjx5yf9iavr3qs1f2b6j0gd8135p5hkg8d8n"))))
+ (base32 "064gnzzcm6fnxfiildbjmgbdxkhqvp61zrl6qhkl1pgbn27j1mll"))))
(build-system haskell-build-system)
(arguments
`(#:phases
@@ -661,7 +661,7 @@ and mIRC chat codes.")
(doc (string-append out "/share/doc/kmonad-" ,version)))
(install-file "README.md" doc)
(copy-recursively "doc" doc)
- (copy-recursively "example" (string-append doc "/example"))
+ (copy-recursively "keymap" (string-append doc "/keymap"))
#t))))))
(inputs
`(("ghc-cereal" ,ghc-cereal)
@@ -670,6 +670,8 @@ and mIRC chat codes.")
("ghc-lens" ,ghc-lens)
("ghc-megaparsec" ,ghc-megaparsec)
("ghc-optparse-applicative" ,ghc-optparse-applicative)
+ ("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-rio" ,ghc-rio)
("ghc-unagi-chan" ,ghc-unagi-chan)
("ghc-unliftio" ,ghc-unliftio)
("ghc-unordered-containers" ,ghc-unordered-containers)))