summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-08-24 12:03:12 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-24 12:03:29 +0300
commit7bcc8004b192f2316beee837521ec251b3d13aca (patch)
tree20aa1a73a9ef78dd74a023fa630c39e224bab6e5 /gnu/packages/haskell-apps.scm
parente9f8a7e21579fd2833dfca6830e21f886a79a9ca (diff)
downloadguix-patches-7bcc8004b192f2316beee837521ec251b3d13aca.tar
guix-patches-7bcc8004b192f2316beee837521ec251b3d13aca.tar.gz
gnu: scroll: Fix build.
* gnu/packages/haskell-apps.scm (scroll)[arguments]: Add custom phase to add a place-holder file to the static output.
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index d1b7772d1c..2a63712083 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -738,6 +738,20 @@ is programmed in Haskell.")
(base32
"0apzrvf99rskj4dbmn57jjxrsf19j436s8a09m950df5aws3a0wj"))))
(build-system haskell-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'touch-static-output
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; The Haskell build system adds a "static" output by
+ ;; default, and there is no way to override this until
+ ;; <https://issues.guix.gnu.org/41569> is fixed. Without
+ ;; this phase, the daemon complains because we do not
+ ;; create the "static" output.
+ (with-output-to-file (assoc-ref outputs "static")
+ (lambda ()
+ (display "static output not used\n")))
+ #t)))))
(inputs
`(("ghc-case-insensitive" ,ghc-case-insensitive)
("ghc-data-default" ,ghc-data-default)