summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2020-11-03 17:04:09 -0500
committerChristopher Lemmer Webber <cwebber@dustycloud.org>2020-11-04 12:03:53 -0500
commit7401f71aec1e75bdceca46711552e53e1f1ec3f1 (patch)
tree401795d9f5e6a1a3ebbfd94da2dc4f7babeac45e /gnu/packages/haskell-apps.scm
parent161e1019fd2110e130082f7bf24a6ab1dbab5dcf (diff)
downloadguix-patches-7401f71aec1e75bdceca46711552e53e1f1ec3f1.tar
guix-patches-7401f71aec1e75bdceca46711552e53e1f1ec3f1.tar.gz
git-annex: Enable pairing and assistant features.
* gnu/packages/haskell-apps.scm (git-annex): Add appropriate dependencies and adjust flags to enable "assistant" and "pairing" features.
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 1de8b040f1..da1bd2128c 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -350,7 +350,7 @@ to @code{cabal repl}).")
(build-system haskell-build-system)
(arguments
`(#:configure-flags
- '("--flags=-Android -Assistant -Pairing -Webapp")
+ '("--flags=-Android -Webapp")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-shell-for-tests
@@ -457,6 +457,7 @@ to @code{cabal repl}).")
("ghc-feed" ,ghc-feed)
("ghc-filepath-bytestring" ,ghc-filepath-bytestring)
("ghc-free" ,ghc-free)
+ ("ghc-hinotify" ,ghc-hinotify)
("ghc-hslogger" ,ghc-hslogger)
("ghc-http-client" ,ghc-http-client)
("ghc-http-conduit" ,ghc-http-conduit)
@@ -466,7 +467,10 @@ to @code{cabal repl}).")
("ghc-memory" ,ghc-memory)
("ghc-monad-control" ,ghc-monad-control)
("ghc-monad-logger" ,ghc-monad-logger)
+ ("ghc-mountpoints" ,ghc-mountpoints)
("ghc-network" ,ghc-network)
+ ("ghc-network-info" ,ghc-network-info)
+ ("ghc-network-multicast" ,ghc-network-multicast)
("ghc-old-locale" ,ghc-old-locale)
("ghc-optparse-applicative" ,ghc-optparse-applicative)
("ghc-persistent" ,ghc-persistent)