summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2022-03-26 23:26:04 -0400
committerLeo Famulari <leo@famulari.name>2022-03-29 12:53:26 -0400
commit6c317e02ee3b41dd7aa3a220be50191b6ed6fe9e (patch)
tree4d9219e5bac5f6907fc1158a589d9e34695e1ed9 /gnu/packages/haskell-apps.scm
parente59069fe2b1cc7bdbd0f872cc4688df41350eba8 (diff)
downloadguix-patches-6c317e02ee3b41dd7aa3a220be50191b6ed6fe9e.tar
guix-patches-6c317e02ee3b41dd7aa3a220be50191b6ed6fe9e.tar.gz
gnu: git-annex: Update to 10.20220322.
* gnu/packages/haskell-apps.scm (git-annex): Update to 10.20220322. [inputs]: Add ghc-http-client-restricted. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index ecd1a93317..5c351fa981 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -304,14 +304,14 @@ to @code{cabal repl}).")
(define-public git-annex
(package
(name "git-annex")
- (version "10.20220222")
+ (version "10.20220322")
(source
(origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"git-annex/git-annex-" version ".tar.gz"))
(sha256
- (base32 "119c7l2vqv19ja3pg3adaivsmrmbyg03a88j2msnzcgyhddggf8z"))))
+ (base32 "107v1c2lw53k25p6snbmxyia3ghd63kj3izvd81d8km9qncv96bv"))))
(build-system haskell-build-system)
(arguments
`(#:configure-flags
@@ -425,6 +425,7 @@ to @code{cabal repl}).")
ghc-hinotify
ghc-hslogger
ghc-http-client
+ ghc-http-client-restricted
ghc-http-conduit
ghc-http-types
ghc-ifelse