summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-30 21:49:41 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-30 22:11:59 +0300
commit4fb1fb904bd0cb605e53dc0dabe63a1422f9d8a1 (patch)
tree36b3fa302b9d301bd86d6418d2b54a6f6f10291a /gnu/packages/haskell-apps.scm
parent9583cbf29c7e5e4817a8e514071796213a6177c4 (diff)
downloadguix-patches-4fb1fb904bd0cb605e53dc0dabe63a1422f9d8a1.tar
guix-patches-4fb1fb904bd0cb605e53dc0dabe63a1422f9d8a1.tar.gz
gnu: git-annex: Update to 10.20220822.
* gnu/packages/haskell-apps.scm (git-annex): Update to 10.20220822. [arguments]: Remove trailing #t from phases.
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 3591d9d67e..50380281d7 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -304,14 +304,14 @@ to @code{cabal repl}).")
(define-public git-annex
(package
(name "git-annex")
- (version "10.20220624")
+ (version "10.20220822")
(source
(origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"git-annex/git-annex-" version ".tar.gz"))
(sha256
- (base32 "0a17ph8w620fmbwhm4yhdz2pwp0z8g5d4qsw2bg8k1par2n8rnmz"))))
+ (base32 "1qv3cb7p2zyc5mpcr4nfgzdmswfny5jbimd2ip7ygh71jlahrbfc"))))
(build-system haskell-build-system)
(arguments
`(#:configure-flags
@@ -326,8 +326,7 @@ to @code{cabal repl}).")
;; let's temporarily patch it so that we can run the tests.
(copy-file "Utility/Shell.hs" "/tmp/Shell.hs")
(substitute* "Utility/Shell.hs"
- (("/bin/sh") (which "sh")))
- #t))
+ (("/bin/sh") (which "sh")))))
(add-before 'configure 'factor-setup
(lambda _
;; Factor out necessary build logic from the provided
@@ -341,12 +340,10 @@ to @code{cabal repl}).")
(call-with-output-file "Setup.hs"
(lambda (out)
(format out "import Distribution.Simple~%")
- (format out "main = defaultMain~%")))
- #t))
+ (format out "main = defaultMain~%")))))
(add-before 'configure 'pre-configure
(lambda _
- (invoke "runhaskell" "PreConf.hs")
- #t))
+ (invoke "runhaskell" "PreConf.hs")))
(add-after 'build 'build-manpages
(lambda _
;; The Setup.hs rewrite above removed custom code for building
@@ -380,8 +377,7 @@ to @code{cabal repl}).")
"/man/man1/")))
(mkdir-p man)
(for-each (lambda (file) (install-file file man))
- (find-files "man")))
- #t))
+ (find-files "man")))))
(add-after 'install 'install-symlinks
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -389,8 +385,7 @@ to @code{cabal repl}).")
(symlink (string-append bin "/git-annex")
(string-append bin "/git-annex-shell"))
(symlink (string-append bin "/git-annex")
- (string-append bin "/git-remote-tor-annex"))
- #t)))
+ (string-append bin "/git-remote-tor-annex")))))
(add-after 'install 'touch-static-output
(lambda* (#:key outputs #:allow-other-keys)
;; The Haskell build system adds a "static" output by