summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-18 04:20:34 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-18 05:38:39 +0200
commit106014094a968048bf42ff5f4a590dbce516c42a (patch)
treeff557354145a4424b8a640b95eb256c95cf916c9 /gnu/packages/haskell-apps.scm
parentfe55ff3851564d9bb72c007d1fe1aac9ea980ac1 (diff)
downloadguix-patches-106014094a968048bf42ff5f4a590dbce516c42a.tar
guix-patches-106014094a968048bf42ff5f4a590dbce516c42a.tar.gz
gnu: ghcid: Update to 0.8.7.
* gnu/packages/haskell-apps.scm (ghcid): Update to 0.8.7.
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index dac626f10a..d1b7772d1c 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -307,15 +307,14 @@ unique algebra of patches called @url{http://darcs.net/Theory,Patchtheory}.
(define-public ghcid
(package
(name "ghcid")
- (version "0.8.4")
+ (version "0.8.7")
(source
(origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/ghcid/"
"ghcid-" version ".tar.gz"))
(sha256
- (base32
- "0wpm4ikrm1krz1ckzwk0srng091yh2skjal4fh95iz1hq3dw6qlw"))))
+ (base32 "0yqc1pkfajnr56gnh43sbj50r7c3r41b2jfz07ivgl6phi4frjbq"))))
(build-system haskell-build-system)
(inputs
`(("ghc-extra" ,ghc-extra)
@@ -326,8 +325,7 @@ unique algebra of patches called @url{http://darcs.net/Theory,Patchtheory}.
(native-inputs
`(("ghc-tasty" ,ghc-tasty)
("ghc-tasty-hunit" ,ghc-tasty-hunit)))
- (home-page
- "https://github.com/ndmitchell/ghcid#readme")
+ (home-page "https://github.com/ndmitchell/ghcid#readme")
(synopsis "GHCi based bare bones IDE")
(description
"Either \"GHCi as a daemon\" or \"GHC + a bit of an IDE\". A very simple Haskell