summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 21:11:12 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:47 -0500
commit0710797d3088bd142be943fa1283c9d47afc458d (patch)
tree7752a725e217f735f16f3502220053fcc94d8fb8 /gnu/packages/haskell-apps.scm
parentb867c2b05115f91fdb6f2561f9fee6775b31797f (diff)
downloadguix-patches-0710797d3088bd142be943fa1283c9d47afc458d.tar
guix-patches-0710797d3088bd142be943fa1283c9d47afc458d.tar.gz
gnu: darcs: Fix Cabal dependency constraints.
* gnu/packages/haskell-apps.scm (darcs): Update the Cabal file to r1 and change the phase that updates the Cabal file to allow for newer versions of 'QuickCheck'.
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 682a10b327..dcaf7e74d5 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -187,7 +187,9 @@ unlit literate code files; and an option to turn off macro-expansion.")
#t))))
(build-system haskell-build-system)
(arguments
- `(#:configure-flags '("-fpkgconfig" "-fcurl" "-flibiconv" "-fthreaded"
+ `(#:cabal-revision
+ ("1" "0xl7j5cm704pbl2ms0dkydh7jvrz0ym76d725ifpg4h902m1zkhg")
+ #:configure-flags '("-fpkgconfig" "-fcurl" "-flibiconv" "-fthreaded"
"-fnetwork-uri" "-fhttp" "--flag=executable"
"--flag=library")
#:phases
@@ -196,6 +198,12 @@ unlit literate code files; and an option to turn off macro-expansion.")
(lambda _
(substitute* "tests/issue538.sh"
(("/bin/sh") (which "sh")))
+ #t))
+ (add-before 'configure 'update-constraints
+ (lambda _
+ (substitute* "darcs.cabal"
+ (("QuickCheck >= 2\\.8\\.2 && < 2\\.13,")
+ "QuickCheck >= 2.8.2 && < 2.14,"))
#t)))))
(inputs
`(("ghc-cmdargs" ,ghc-cmdargs)