summaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-01-02 11:38:03 -0500
committerLeo Famulari <leo@famulari.name>2022-01-06 13:18:19 -0500
commitfb8568857fbbfc46c01c47099da364639ca69d88 (patch)
treea7be760cbe34495ffd079eeb836f65498b9b4991 /gnu/packages/hardware.scm
parent2860bb2779dbc557ab5362b531d9f497f34b41d8 (diff)
downloadguix-patches-fb8568857fbbfc46c01c47099da364639ca69d88.tar
guix-patches-fb8568857fbbfc46c01c47099da364639ca69d88.tar.gz
gnu: Add hueplusplus.
* gnu/packages/hardware.scm (hueplusplus): New variable. * gnu/packages/patches/hueplusplus-mbedtls.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm38
1 files changed, 37 insertions, 1 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 28647477fe..5ba7a5e9ec 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
-;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2021, 2022 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -341,6 +341,42 @@ headsets. Currently, support is provided for adjusting sidetone, getting
battery state, controlling LEDs, and setting the inactive time.")
(license license:gpl3+)))
+(define-public hueplusplus
+ (package
+ (name "hueplusplus")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/enwi/hueplusplus")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jy8m2a0h0kf0aw8jbniz069q9j7cx67b1zlv2vz1ymq921qk0pm"))
+ (patches
+ (search-patches "hueplusplus-mbedtls.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;; Tests require Google's gtest and gmock
+ (inputs
+ (list mbedtls-apache))
+ (synopsis "C++ library to control Philips Hue lights")
+ (description "Hueplusplus is a library for controlling Philips Hue lights.
+Features:
+
+@itemize
+@item find bridges with SSDP or set an ip manually
+@item all common light functions (brightness, color, temperature)
+@item extended @code{alert()} functions, which alert in a specific
+color (good for notifications)
+@item supports sensors, rules, groups, scenes and schedules
+@item streaming with entertainment mode
+@item documented with doxygen
+@end itemize")
+ (home-page "https://github.com/enwi/hueplusplus")
+ (license license:lgpl3+)))
+
(define-public i7z
(let ((revision "0")
(commit "1a41ff13db747e962456ddbb5ccb2b7fc43ca0cb"))