summaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorEvgeny Pisemsky <evgeny@pisemsky.com>2021-01-05 05:30:00 +0300
committerMathieu Othacehe <othacehe@gnu.org>2021-01-07 18:16:57 +0100
commitec732a46febd5dee0e4d116caed7b259f882f7c7 (patch)
tree2a54046810d542d35b653dfef04045e215debb36 /gnu/packages/hardware.scm
parenta0f019b81f9e58bc1290a0d7426cc9558fbed568 (diff)
downloadguix-patches-ec732a46febd5dee0e4d116caed7b259f882f7c7.tar
guix-patches-ec732a46febd5dee0e4d116caed7b259f882f7c7.tar.gz
gnu: Add screentest.
* gnu/packages/hardware.scm (screentest): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index d130ebd48b..3da6759472 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2021 Evgeny Pisemsky <evgeny@pisemsky.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,6 +30,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages gcc)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages ncurses)
@@ -465,3 +467,34 @@ authorization policies (what kind of USB devices are authorized) as well as
method of use policies (how a USB device may interact with the system).
Simply put, it is a USB device whitelisting tool.")
(license license:gpl2)))
+
+(define-public screentest
+ (package
+ (name "screentest")
+ (version "2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TobiX/screentest")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gv3xj9sbk1wsyijfw9xjnvy8pg7j4arjnma2r2kfi18qy32wd30"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+-2)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("intltool" ,intltool)
+ ("libtool" ,libtool)
+ ("glib" ,glib "bin")
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Simple screen testing tool")
+ (description "This is a program for testing the quality of CRT/LCD
+screens. It displays various patterns and allows you to estimate the quality
+of your CRT/LCD monitor.")
+ (home-page "https://github.com/TobiX/screentest")
+ (license license:gpl2)))