summaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-29 01:06:53 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-29 01:08:17 +0200
commita8b705252bdcb642999258859ada1c2f43706092 (patch)
tree71fea7ce6a58a02ae0e1678a5b820c5b372da79b /gnu/packages/hardware.scm
parent05528dcd4827ef449e2014794ab74085e57651b9 (diff)
downloadguix-patches-a8b705252bdcb642999258859ada1c2f43706092.tar
guix-patches-a8b705252bdcb642999258859ada1c2f43706092.tar.gz
gnu: Add i7z.
* gnu/packages/hardware.scm (i7z): New public variable.
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index ecbcca79b1..e7dd4a1fa7 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -137,6 +137,53 @@ calibrated, and restored when the calibration is applied.")
human-readable format and checks if it conforms to the standards.")
(license license:expat))))
+(define-public i7z
+ (let ((revision "0")
+ (commit "1a41ff13db747e962456ddbb5ccb2b7fc43ca0cb"))
+ (package
+ (name "i7z")
+ (version (git-version "0.28" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/afontenot/i7z")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jxm63a8y1mfl1sa4mzzfs3bgnym6achj1yc0jglmp05xal16lm1"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (for-each delete-file-recursively
+ (list "src/GUI"
+ "src/perfmon-i7z"
+ "scripts"))))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "prefix=" (assoc-ref %outputs "out"))
+ (string-append "CC=" ,(cc-for-target)))
+ #:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (home-page "https://github.com/afontenot/i7z")
+ (synopsis "Thermal and C-state reporting on older Intel Core CPUs")
+ (description
+ "The @command{i7z} utility accurately measures the current frequency
+and temperature of older Intel Core (i3, i5, and i7) processors including the
+Nehalem, Sandy Bridge, and Ivy Bridge generations. Reliable support for newer
+CPUs is not guaranteed, as this package has not seen significant development
+since 2013.
+
+If your processor is supported, you'll get detailed reports on Turbo Boost and
+clock multipliers, core voltage, and time spent in different C-states. This
+information can be viewed in real time and/or logged to a file.")
+ (license license:gpl2))))
+
(define-public libsmbios
(package
(name "libsmbios")