summaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-14 00:57:55 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-14 19:35:23 +0100
commita0fd9a35321438cba2f380c339d1c11f4e4750d7 (patch)
tree217db243e5b75cdd3d1984b320a65e4d35870a18 /gnu/packages/hardware.scm
parent5ee8589c867030bed4405b8a9724be5ca40eb29e (diff)
downloadguix-patches-a0fd9a35321438cba2f380c339d1c11f4e4750d7.tar
guix-patches-a0fd9a35321438cba2f380c339d1c11f4e4750d7.tar.gz
gnu: i7z: Fix building with GCC >= 10.
* gnu/packages/hardware.scm (i7z)[source]: Add patch. * gnu/packages/patches/i7z-gcc-10.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 7f6e858ee0..ddd0f5acc1 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -25,6 +25,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages hardware)
+ #:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
@@ -330,6 +331,8 @@ whether the hardware works with a fully free operating system or not.")
(file-name (git-file-name name version))
(sha256
(base32 "0jxm63a8y1mfl1sa4mzzfs3bgnym6achj1yc0jglmp05xal16lm1"))
+ (patches
+ (search-patches "i7z-gcc-10.patch"))
(modules '((guix build utils)))
(snippet
'(begin