summaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-02 20:29:12 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-02 20:50:19 +0200
commit907b9dc8cb87a2ef831627185b4cb08576b87622 (patch)
treea9f10d227de9e03516d27546404268529e0950bb /gnu/packages/hardware.scm
parentae05ac8fd2e7b464fb61a3c46e9e2baf88d2abdb (diff)
downloadguix-patches-907b9dc8cb87a2ef831627185b4cb08576b87622.tar
guix-patches-907b9dc8cb87a2ef831627185b4cb08576b87622.tar.gz
gnu: memtester: Fix cross-compilation.
* gnu/packages/hardware.scm (memtester)[arguments]: Use CC-FOR-TARGET.
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 7ebe8f48eb..6a2e2c695b 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -43,7 +43,8 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages))
+ #:use-module (guix packages)
+ #:use-module (guix utils))
;; This is a module for packages related to physical hardware that don't (yet)
;; have a more specific home like gps.scm, security-token.scm, &c.
@@ -203,7 +204,7 @@ Memtest86+ cannot currently be used on computers booted with UEFI.")
(build-system gnu-build-system)
(arguments
`(#:make-flags
- (list "CC=gcc")
+ (list ,(string-append "CC=" (cc-for-target)))
#:phases
(modify-phases %standard-phases
(replace 'configure