summaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2021-08-18 03:13:56 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-08-30 18:20:07 +0200
commit7c3cefde5a4f8a5a141561493435005b94b1c970 (patch)
treee711ba019e81470316213434b4f8a851416818ff /gnu/packages/hardware.scm
parent07328706313bc52a1ad5842e02bd0c50e5312833 (diff)
downloadguix-patches-7c3cefde5a4f8a5a141561493435005b94b1c970.tar
guix-patches-7c3cefde5a4f8a5a141561493435005b94b1c970.tar.gz
gnu: Add h-client.
* gnu/packages/hardware.scm (h-client): New variable. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 707a47fb4b..ff21c9c724 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2021 Evgeny Pisemsky <evgeny@pisemsky.com>
;;; Copyright © 2021 Léo Le Bouter <lle-bout@zaclys.net>
+;;; Copyright © 2021 Denis Carikli <GNUtoo@cyberdimension.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,11 +39,14 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages openldap)
+ #:use-module (gnu packages pciutils)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages polkit)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-web)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
@@ -51,8 +55,10 @@
#:use-module (gnu packages xorg)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix svn-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils))
@@ -169,6 +175,46 @@ through the Display Data Channel Command Interface (@dfn{DDC/CI}) protocol.")
human-readable format and checks if it conforms to the standards.")
(license license:expat))))
+(define-public h-client
+ (let ((version "0.0a0")
+ (revision 138))
+ (package
+ (name "h-client")
+ (version (string-append version "-" (number->string revision)))
+ (source
+ (origin
+ (method svn-fetch)
+ (uri
+ (svn-reference
+ (url "https://svn.savannah.nongnu.org/svn/h-client/trunk/h-client")
+ (revision revision)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pdd2qhyaa5vh7z4rkpwjlby1flkwhzmp8zlglalx5y5sv95l4kp"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ ;; Tests depends on /etc/os-release which does not exist in the
+ ;; build container.
+ #:tests? #f))
+ (inputs
+ `(("python2" ,python-2)
+ ("python2-pycurl", python2-pycurl)
+ ("python2-pygtk", python2-pygtk)
+ ("pciutils", pciutils)
+ ("usbutils", usbutils)))
+ (synopsis "Graphical client for the h-node hardware database
+project")
+ (description
+ "The h-node project (https://www.h-node.org) aims to build a database of
+hardware that works with fully free operating systems.
+h-client is a GTK+ graphical client that is able to retrieves information on
+the hardware inside the computer it's running on, and on peripherals connected
+to it, and help you submit that information to the h-node project along with
+whether the hardware works with a fully free operating system or not.")
+ (home-page "https://savannah.nongnu.org/projects/h-client/")
+ (license license:gpl3+))))
+
(define-public i7z
(let ((revision "0")
(commit "1a41ff13db747e962456ddbb5ccb2b7fc43ca0cb"))