summaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-17 00:45:06 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-28 00:44:11 +0200
commit0cd05b5e5c1373cd60fe1e426de967fd8908ed0a (patch)
tree10e82e5bb3392e435a69b3824e07efd43f686065 /gnu/packages/hardware.scm
parentc9c4c851a8f05228e060d2d12550d31c2dced5b4 (diff)
downloadguix-patches-0cd05b5e5c1373cd60fe1e426de967fd8908ed0a.tar
guix-patches-0cd05b5e5c1373cd60fe1e426de967fd8908ed0a.tar.gz
gnu: Add openhmd.
* gnu/packages/hardware.scm (openhmd): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index e64055c4a5..2bf3576d5a 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2021 Denis Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -59,6 +60,7 @@
#:use-module (gnu packages xorg)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -568,6 +570,32 @@ MSR addresses differ (greatly) between processors, and any such modification can
be dangerous and may void your CPU or system board's warranty.")
(license license:gpl2))) ; cpuid.c is gpl2, {rd,wr}msr.c are gpl2+
+(define-public openhmd
+ (package
+ (name "openhmd")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenHMD/OpenHMD")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hkpdl4zgycag5k8njvqpx01apxmm8m8pvhlsxgxpqiqy9a38ccg"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:tests? #f)) ; no test target although there is a test folder
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("hidapi" ,hidapi)))
+ (home-page "http://www.openhmd.net/")
+ (synopsis "API and drivers for immersive technology")
+ (description "OpenHMD aims to provide an API and drivers for immersive
+technology, such as head mounted displays with built in head tracking.")
+ (license license:boost1.0)))
+
(define-public wavemon
(package
(name "wavemon")