summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-28 12:44:02 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-10-10 16:19:50 +0300
commitf9fbed011e51def23bf6f141f4dbcbbcce1669d2 (patch)
treeb093cc945dd52ab562bf4e25e2257bd8eb9754e4 /gnu/packages/guile.scm
parent697686805f473ca896f685adb840fa66654d8e49 (diff)
downloadguix-patches-f9fbed011e51def23bf6f141f4dbcbbcce1669d2.tar
guix-patches-f9fbed011e51def23bf6f141f4dbcbbcce1669d2.tar.gz
gnu: guile: Fix building on riscv64-linux.
* gnu/packages/guile.scm (guile-3.0)[arguments]: On riscv64-linux add a phase to skip a failing test.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index c1a551f56a..df75389760 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -362,14 +362,17 @@ without requiring the source code to be rewritten.")
;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=45214
(substitute* "bootstrap/Makefile.in"
(("^GUILE_OPTIMIZATIONS.*")
- "GUILE_OPTIMIZATIONS = -O1 -Oresolve-primitives -Ocps\n"))))
- (add-after 'unpack 'skip-failing-fdes-test
- (lambda _
- ;; ERROR: ((system-error "seek" "~A" ("Bad file descriptor") (9)))
- (substitute* "test-suite/tests/ports.test"
- (("fdes not closed\"" all) (string-append all "(exit 77)")))
- #t)))
- '())))))
+ "GUILE_OPTIMIZATIONS = -O1 -Oresolve-primitives -Ocps\n")))))
+ '())
+ ,@(if (or (target-ppc32?)
+ (target-riscv64?))
+ `((add-after 'unpack 'skip-failing-fdes-test
+ (lambda _
+ ;; ERROR: ((system-error "seek" "~A" ("Bad file descriptor") (9)))
+ (substitute* "test-suite/tests/ports.test"
+ (("fdes not closed\"" all) (string-append all "(exit 77)")))
+ #t)))
+ '())))))
(native-search-paths
(list (search-path-specification