summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-14 18:09:50 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-14 18:31:35 +0100
commitf63495d31bf5acad00b6ee5f44a0553a67ee91fb (patch)
treeaf3ed054e9e3784670ef55f5ae6480aaab551be6 /gnu/packages/guile.scm
parente8b79cd9f449c0419f1d4f09d7b8e0712b6a961f (diff)
downloadguix-patches-f63495d31bf5acad00b6ee5f44a0553a67ee91fb.tar
guix-patches-f63495d31bf5acad00b6ee5f44a0553a67ee91fb.tar.gz
gnu: guile: Apply Shepherd fix to the default Guile.
* gnu/packages/guile.scm (guile-2.2/bug-fix): Remove variable. (guile-2.2)[source](patches): Add "guile-finalization-crash.patch". * gnu/packages/admin.scm (shepherd)[inputs, native-inputs]: Change from GUILE-2.2/BUG-FIX to GUILE-2.2.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index c0743269fc..7b6009770d 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -230,6 +230,7 @@ without requiring the source code to be rewritten.")
"1269ymxm56j1z1lvq1y42rm961f2n7rinm3k6l00p9k52hrpcddk"))
(modules '((guix build utils)))
(patches (search-patches
+ "guile-finalization-crash.patch"
"guile-2.2-skip-oom-test.patch"))
;; Remove the pre-built object files. Instead, build everything
@@ -250,18 +251,6 @@ without requiring the source code to be rewritten.")
(variable "GUILE_LOAD_COMPILED_PATH")
(files '("lib/guile/2.2/site-ccache")))))))
-(define-public guile-2.2/bug-fix
- ;; This variant contains a bug fix for a relatively rare crash that could
- ;; affect shepherd as PID 1: <https://bugs.gnu.org/37757>.
- (package
- (inherit guile-2.2)
- (version (string-append (package-version guile-2.2) "-1"))
- (source (origin
- (inherit (package-source guile-2.2))
- (patches
- (append (search-patches "guile-finalization-crash.patch")
- (origin-patches (package-source guile-2.2))))))))
-
(define-public guile-2.2/fixed
;; A package of Guile 2.2 that's rarely changed. It is the one used
;; in the `base' module, and thus changing it entails a full rebuild.