summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-10 20:54:52 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-10 20:54:52 +0100
commitedc8fd2e2d75ba7af9bf6403277ecb0dccd48dc3 (patch)
treeb9da9549c0df1b379536253ef80211138aa9a2d7 /gnu/packages/guile.scm
parent50b99c90c87642f664f9c9523a6e40fc8542ddcf (diff)
downloadguix-patches-edc8fd2e2d75ba7af9bf6403277ecb0dccd48dc3.tar
guix-patches-edc8fd2e2d75ba7af9bf6403277ecb0dccd48dc3.tar.gz
gnu: Remove guile@2.2.6.
* gnu/packages/patches/guile-finalization-crash.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/guile.scm (guile-2.2)[source](patches): Remove 'guile-finalization-crash.patch'. (guile-2.2.7): Remove variable. (guile-2.2/bug-fix): Point to GUILE-2.2. * gnu/packages/admin.scm (shepherd)[native-inputs, inputs]: Use GUILE-2.2 instead of GUILE-2.2.7.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm21
1 files changed, 3 insertions, 18 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 0ce5d71cfd..b97f149391 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -217,7 +217,7 @@ without requiring the source code to be rewritten.")
(define-public guile-2.2
(package (inherit guile-2.0)
(name "guile")
- (version "2.2.6")
+ (version "2.2.7")
(source (origin
(method url-fetch)
@@ -227,10 +227,9 @@ without requiring the source code to be rewritten.")
".tar.xz"))
(sha256
(base32
- "1269ymxm56j1z1lvq1y42rm961f2n7rinm3k6l00p9k52hrpcddk"))
+ "013mydzhfswqci6xmyc1ajzd59pfbdak15i0b090nhr9bzm7dxyd"))
(modules '((guix build utils)))
(patches (search-patches
- "guile-finalization-crash.patch"
"guile-2.2-skip-oom-test.patch"))
;; Remove the pre-built object files. Instead, build everything
@@ -251,21 +250,7 @@ without requiring the source code to be rewritten.")
(variable "GUILE_LOAD_COMPILED_PATH")
(files '("lib/guile/2.2/site-ccache")))))))
-(define-public guile-2.2.7
- ;; This version contains a bug fix for a relatively rare crash that could
- ;; affect shepherd as PID 1: <https://bugs.gnu.org/37757>.
- (package
- (inherit guile-2.2)
- (version "2.2.7")
- (source (origin
- (inherit (package-source guile-2.2))
- (uri (string-append "mirror://gnu/guile/guile-" version
- ".tar.xz"))
- (sha256
- (base32
- "013mydzhfswqci6xmyc1ajzd59pfbdak15i0b090nhr9bzm7dxyd"))))))
-
-(define-deprecated guile-2.2/bug-fix guile-2.2.7)
+(define-deprecated guile-2.2/bug-fix guile-2.2)
(define-public guile-2.2/fixed
;; A package of Guile 2.2 that's rarely changed. It is the one used