summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-28 22:06:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-28 22:06:35 +0100
commite8bc2a01e9ae69c72367a3d59a6ee29145ca1052 (patch)
treebbedbc595472648e9f6bfc899785535bc4d2ee64 /gnu/packages/guile.scm
parent3299d8ef7c7454a8568965da1b34f602a5221c65 (diff)
downloadguix-patches-e8bc2a01e9ae69c72367a3d59a6ee29145ca1052.tar
guix-patches-e8bc2a01e9ae69c72367a3d59a6ee29145ca1052.tar.gz
gnu: Adjust 'package-for-guile-2.0' for the Guile 3 switch.
* gnu/packages/guile.scm (package-for-guile-2.0): Rewrite GUILE-3.0 instead of GUILE-2.2.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 0efee2d86a..5e333c9586 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -371,8 +371,8 @@ GNU@tie{}Guile. Use the @code{(ice-9 readline)} module and call its
(define package-for-guile-2.0
;; A procedure that rewrites the dependency tree of the given package to use
- ;; GUILE-2.0 instead of GUILE-2.2.
- (package-input-rewriting `((,guile-2.2 . ,guile-2.0))
+ ;; GUILE-2.0 instead of GUILE-3.0.
+ (package-input-rewriting `((,guile-3.0 . ,guile-2.0))
(guile-variant-package-name "guile2.0")))
(define package-for-guile-2.2