summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-23 14:07:34 +0200
committerMarius Bakke <marius@gnu.org>2021-05-23 17:49:56 +0200
commitdbcf2b61b1f48cbe84d51873f4e4de60897b914c (patch)
tree92dc5d19b2899a91d22a53fb1a6e6f3ffedd8d2c /gnu/packages/guile.scm
parent9351b2a48145a690484ff38ace0ccb828c204c09 (diff)
downloadguix-patches-dbcf2b61b1f48cbe84d51873f4e4de60897b914c.tar
guix-patches-dbcf2b61b1f48cbe84d51873f4e4de60897b914c.tar.gz
gnu: Fix erroneous uses of 'package/inherit'.
These packages use a different source/version from the inherited package, and thus should not inherit replacements. * gnu/packages/check.scm (googletest-1.8, python-pytest-runner-2): Use record inheritance instead of PACKAGE/INHERIT. * gnu/packages/crates-io.scm (rust-bindgen-0.49, rust-bytes-0.4, rust-colored-1.9.1, rust-difference-1, rust-docopt-0.8, rust-html5ever-0.23, rust-http-0.1, rust-http-body-0.1, rust-loom-0.2, rust-loom-0.1, rust-pulldown-cmark-0.0.8, rust-ring-0.13, rust-rustls-0.12, rust-sct-0.3, rust-term-0.2, rust-untrusted-0.6, rust-webpki-0.18, rust-webpki-roots-0.17, rust-webpki-roots-0.14): Likewise. * gnu/packages/emacs.scm (emacs-next, emacs-next-pgtk, guile-emacs): Likewise. * gnu/packages/guile.scm (guile-2.2.4): Likewise. * gnu/packages/maths.scm (hdf5-1.10, hdf5-1.12): Likewise. * gnu/packages/protobuf.scm (protobuf-3.6, protobuf-3.5, python-protobuf-3.6): Likewise. * gnu/packages/python-web.scm (python2-html2text): Likewise. * gnu/packages/python-xyz.scm (python-pygments/fixed, python2-numpy, python2-urwid, python2-markdown, python2-fonttools): Likewise. * gnu/packages/racket.scm (racket): Likewise. * gnu/packages/sequoia.scm (sequoia4pEp): Likewise.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 74c0709ea4..5de4f68093 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -269,8 +269,8 @@ without requiring the source code to be rewritten.")
(define-deprecated guile-2.2/bug-fix guile-2.2)
(define-public guile-2.2.4
- (package/inherit
- guile-2.2
+ (package
+ (inherit guile-2.2)
(version "2.2.4")
(source (origin
(inherit (package-source guile-2.2))