summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-06-20 13:50:22 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-20 14:07:01 +0200
commitc050f1870016a6bf6e79aee8e5abe5da366fa210 (patch)
treef54b490e257049f2839d45c9064b0c1c0af6a3fd /gnu/packages/guile.scm
parentbecb9cbfe1e2fb70da940e989f56be17abe31133 (diff)
downloadguix-patches-c050f1870016a6bf6e79aee8e5abe5da366fa210.tar
guix-patches-c050f1870016a6bf6e79aee8e5abe5da366fa210.tar.gz
gnu: guile: Add 2.2.5.
* gnu/packages/guile.scm (guile-2.2.5): New variable.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 67825ffc30..f0a53e7c39 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -286,6 +286,18 @@ without requiring the source code to be rewritten.")
(max-silent-time . 36000))))) ;10 hours (needed on ARM
; when heavily loaded)
+(define-public guile-2.2.5
+ (package
+ (inherit guile-2.2)
+ (version "2.2.5")
+ (source (origin
+ (inherit (package-source guile-2.2))
+ (uri (string-append "mirror://gnu/guile/guile-" version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "19w5ws1jvs01dpv756qv2cgs37rsnwq1f4f07mj0wra35pqp6c7w"))))))
+
(define-public guile-next
;; This is the upcoming Guile 3.0, with JIT support.
(let ((commit "6f3357b0df64c4be17e72079864c09a542f1c779")